[Shorewall-users] ssh and ftp

varun_saa at vsnl.net varun_saa at vsnl.net
Thu Mar 31 02:01:27 PST 2005



----- Original Message -----
From: Jeff <jsoehner at the-techy.com>
Date: Wednesday, March 30, 2005 5:37 pm
Subject: Re: [Shorewall-users] ssh and ftp

> Well I generally attempt to verify a problem like this by using a 
> machine on
> MY LAN and typing...
> 
> telnet mygate 22
> 
> and if it works (press enter twice) I get...
> 
> SSH-1.99-OpenSSH_3.9p1
>                      Protocol mismatch.
> 
> 
> Connection to host lost.
> 
> This tells me that the port is open and listening and that there is 
> nothingpreventing me from connecting to my firewall using ssh 
> (except perhaps a ssh
> configuration entry).I imagine you have tried something similar? 
> Have you
> also reviewed the logs on your firewall that shorewall generates? 
> You may
> also seek 'good' help by following the support guide located at the 
> bottomof your OP. I see none of this information included anywhere 
> in your post...
> 
> Jeff
> 
> I ran nmap on a client and server and in both cases 
it showed that the port 21 and 22 were open.

Myserver is on Mandrake 10.1
eth0 as WAN with static IP connected to 512K DSL
eth1 is LAN


>From the client I am able to telnet both port 21 and 22
over LAN to the myserver.


>From the client and myserver I am able to :
 
telnet mygateway 21


>From the client I am able to :

telnet myserver 22

Or 

ssh myserver


But from the client or myserver I am not :

telnet mygateway 22


Any idea what is wrong ?

Thanks

Varun



More information about the Shorewall-users mailing list